Delayed publishing to Maven Central

Incident Report for Maven Central

Resolved

The incident has been resolved. Maven Central publishing is operating normally.
Posted Feb 28, 2026 - 12:59 EST

Monitoring

The infrastructure issue causing the publishing delays has been resolved. The ingest pipeline is now actively processing the backlog of queued publications. Artifacts submitted during the delay period are being published in order and will appear on Maven Central shortly. We are monitoring the pipeline to confirm all pending publications are processed successfully.
Posted Feb 28, 2026 - 12:24 EST

Investigating

We are currently experiencing delays in publishing artifacts to Maven Central. The ingest pipeline is facing processing delays due to an infrastructure issue.

As a result, new publications submitted through the Central Portal are currently queued and have not yet been ingested. All pending publications will be processed once the infrastructure issue is resolved.

Our team is working to address the situation, and we will provide updates as they become available.
Posted Feb 28, 2026 - 09:45 EST
This incident affected: Portal - central.sonatype.com.