Long waits in publishing times on central.sonatype.com

Incident Report for Maven Central

Resolved

The Jenkins infrastructure issue has been resolved and publishing deployments are operating normally. Thank you for your patience.
Posted Apr 30, 2026 - 13:57 EDT

Monitoring

The Jenkins infrastructure issue has been resolved and publishing jobs are now running. There is a backlog of deployments that will take some time to clear. We appreciate your patience.
Posted Apr 30, 2026 - 10:08 EDT

Investigating

We are currently experiencing delays in publishing deployments due to a Jenkins infrastructure issue. A large publishing job kicked off earlier this afternoon can take several hours to complete. Once it finishes, the backlog will begin to clear. We are actively monitoring and will reach out to publishers if any manual intervention is needed. We appreciate your patience.
Posted Apr 30, 2026 - 08:33 EDT
This incident affected: Portal - central.sonatype.com.