Intermittent Timeout Errors from search.maven.org
Incident Report for Maven Central
Resolved
We've been monitoring our most recent changes for the past day, and error rates seem to be back to where they were before this incident.
Posted Jan 20, 2023 - 21:31 EST
Monitoring
We scaled up the cluster backing search.maven.org over the weekend, but that only helped reduce the rate of 504 errors versus eliminating them entirely. We recently adjusted our deployment process, and that has seemed to have a positive effect on reducing 5xx errors in general. We will continue to observe performance before resolving this incident.
Posted Jan 19, 2023 - 12:20 EST
Investigating
We are currently investigating user reports of intermittent timeout (504) errors from search.maven.org. These are particularly evident when using tooling that makes REST API calls, but users browsing the search.maven.org website are also impacted because the 504 errors prevent results from being returned. Under current load, it seems like 1 in 4 results end in a timeout or 504 error.
Posted Jan 13, 2023 - 08:07 EST
This incident affected: Central (Search - search.maven.org).