Staging operations on oss.sonatype.org running extremely long
Incident Report for Maven Central
Resolved
This incident has been resolved.
Posted Feb 06, 2021 - 00:20 EST
Update
We've completed a restart and are allowing staging operations again.
Posted Feb 05, 2021 - 11:45 EST
Investigating
oss.sonatype.org will be restarted shortly. Even after it returns, we may need to pause staging operations. We're also offering to migrate users to a new host: https://twitter.com/Brian_Fox/status/1357414532512104448
Posted Feb 05, 2021 - 10:38 EST
Monitoring
Staging operation times seem to be much better, though that may have less to do with work we've done on our end and may just be a product of reduced load at this time of day. We may need to schedule further restarts if performance bogs down again. We're keeping the status at "Degraded performance" for this reason.
Posted Feb 04, 2021 - 15:15 EST
Investigating
Some time overnight, staging operations on oss.sonatype.org started taking longer and longer, and the current average for completion time is well above the 300 second default timeout. We're currently investigating and may have to restart oss.sonatype.org or pause staging operations to provide some relief.
Posted Feb 04, 2021 - 10:00 EST
This incident affected: Central (Publishing - oss.sonatype.org).